[INVALID_TYPE] sObject type is not supported

[INVALID_TYPE] sObject type <object> is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name. Please reference your WSDL or the describe call for the appropriate names.

 

Symptom

When our application attempts to log a Conversation record and Salesforce Activity record, it may trigger other records to be created too, such as our Call Flow and Call Flow Step records in the case of an inbound call to a Call Flow. You may also also have automations that trigger on a Task being created/updated which creates other records.

This error prevents the conversation activity from being created in Salesforce successfully.

 

Cause

When a record fails to be created because a user doesn't have permission in Salesforce to create records of that object type, this error will be encountered.

For this example, we will focus on our Call Flow object, but these concepts apply to any object type identified in the error between the single quotes: sObject type 'call_flow__c' is not supported

 

Troubleshooting

If you are encountering this issue with the Call Flor or Call Flow Steps objects, you should ensure the user has the "RingDNA Agent Permission Set" applied.

To resolve this issue for a different object identified, you will need to grant create/edit access in Salesforce to that object via the user's Profile or a Permission Set in Salesforce.

At the individual profile level — In Salesforce, navigate to Setup > Profiles and click into the profile possessed by the affected user(s).

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Once inside, click on Object Settings, then scroll through the resulting entries until you reach Call Flows and Call Flow Steps.

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By clicking into each entry respectively (Call Flows and Call Flow Steps), change the permissions for each so that Read, Create, Edit, and Delete are checked, and Save the changes.

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