Dropped calls can have a number of causes, depending on whether you are calling out to a landline or someone’s mobile phone.
Symptoms
A dropped call is one which (after successful connection) suddenly ends. While you or your customer are speaking the call will go silent and you will be disconnected from the call.
Do not confuse a dropped call with failure to connect. In some rare instances "bad" phone numbers will simply not connect and appear as if RingDNA Dialer is silent or doing nothing.
Causes
Dropped calls can have a number of causes, depending on whether you are calling out to a landline or someone’s mobile phone.
If you are calling someone’s mobile number, issues can arise from loss of signal between cellular towers, dead phone batteries, or other environmental factors blocking the signal. A dropped call can be the result of phone issues on the side of the person you are calling.
Troubleshoot: (VOIP / WebRTC / Softphone calls)
- If the person you are calling is using a mobile phone, try calling them on a landline
- Restart your computer
- Use a direct network connection (not WiFi)
- Use a wired headset (not Bluetooth)
- Change physical location, take calls from a different network, office or home
- If you are not using Call Forwarding: (VOIP / WebRTC / Softphone calls)
- Try turning on the Call Forwarding function to send calls to a mobile or office phone
- If you are using Call Forwarding:
- Try using a different Call Forwarding forwarding device (mobile / desk phone etc.)
- OR - Turn off Call Forwarding and use the WebRTC / VOIP softphone
If none of these options resolve your issue, it might help to check with the administrator of your local network to see if you are experiencing packet loss.
Note: Serious dropped call problems frequently exhibit patterns, such as every call dropping at exactly 10 seconds.
Contact Support
If you are still experiencing issues, contact Support:
- Submit a call report to Revenue in the RingDNA Dialer (if you have not already done so)
- Categorize the call as Dropped Call.
- Provide as many call reports related to the issue as possible.
- For audio quality issues, it’s helpful to provide a sense of severity.
- Provide this feedback in the call report ‘Note’ field after clicking “Report this Call”
- What sounds did you hear?
- What issues did you encounter?
- Does there appear to be a particular country or region where you experience issues more acutely?
- Contact support directly
- Email: support@revenue.io
- Phone: 888-815-0802 (option #2)