Troubleshooting
Summary
There appears to be a problem with your Salesforce Connect User, which is currently johndoe@revenue.io.Account Name: Revenue.io Labs
Salesforce Org ID: 00Def000007ABCrXYZ
First user on the account: John Doe
Date Created: Apr 26, 2022 4:20:55 PM
Symptom
An Administrator will receive an email notification indicating that there is a problem with their Salesforce Connect User account.The Salesforce Connect User is also referred to as an Integration User, that is largely responsible for maintaining a connection between an organization’s Salesforce account and their Revenue.io account.
If Call Flows and Queues are being utilized in ringDNA, the Salesforce Connect User is used to create tasks for abandoned Queue and calls that reach a Queue voicemail where there is no obvious owner
The Salesforce Connect User is also utilized for creating Leads in Salesforce when calls are routed through a Marketing Call Tracking number.
Cause
The Salesforce Connect User’s login session token is no longer valid.
- Most commonly, the user’s password has been reset which revokes all current session tokens.
- If the user is no longer “Active” in Salesforce, or their account has been deleted, that will break the connection to Salesforce.
- If the error is being encountered in a Sandbox, it may have been refreshed recently which revokes the session token.
Troubleshooting
If your Connect User has reset their Salesforce Password recently, their login session may no longer be valid:- Navigate to https://app.ringdna.net
- Login with your Salesforce Connect User's credentials to reauthenticate and grant access to ringDNA.
- Navigate to https://app.ringdna.net
- Click on Account | Under Account | Click the Salesforce tab |
- Scroll down to Salesforce Connect User settings | Choose your new Connect User
- Click Save at the top of the page
Please send the new sandbox Org ID to support@revenue.io
- For Classic: Click on Setup | Under Administer | Company Profile | Company Information
- For Lightning: Click on Gear Icon | Setup | Company Settings | Company information