Error: Attempt to de-reference a null object

Symptom

Guided Selling Administrators receive multiple emails from the Revenue.io App similar to the one below. 

Guided Selling Encountered this error:
Contacts.processDelegationChanges | Attempt to de-reference a null object

Cause

The Guided Selling application will periodically execute batches which may reference lookup fields if they are present in a Lead or Contact Field Set. One such field has been found to cause issues if it's present in a Field Set: ReportsTo

When this field is present in the Field Set, it causes an exception during the Before Update Trigger which leads to an empty list that gets dereferenced in the After Update trigger.

Solution

Remove the ReportsTo field from the Contact Object's Field Set: Guided Selling by Revenue.io Contact Field Set

  1. Navigate to Salesforce Setup
  2. Click Object Manager
  3. Click Contact from the object list
  4. Select Field Set in the left navigation menu
  5. Open the Field Set: Guided Selling by Revenue.io Contact Field Set
  6. Remove the ReportsTo field
  7. Click Save

For detailed instructions and screenshots, see Managing Contact Field Sets.

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